Problems with JACK Setup

Programming applications for making music on Linux.

Moderators: khz, MattKingUSA

fork
Posts: 1
Joined: Mon Apr 10, 2017 2:35 am

Problems with JACK Setup

Postby fork » Mon Apr 10, 2017 2:52 am

I've built a few Linux OSs for use by audiophiles with music playback, using RT kernels and JACK. Eliminating latency does improve sound quality slightly with some digital converters.

With my most recent Manjaro build, JACK seems to be working (connects and runs) and RhythmBox plays music files, but they're not working together. I believe Pulse Audio is taking over playback. I don't see any settings in RhythmBox to change this.

Can anyone tell me what I should do to ditch Pulse and get JACK working...delete pulse, additional config, etc?

User avatar
tramp
Establlshed Member
Posts: 1094
Joined: Mon Jul 01, 2013 8:13 am

Re: Problems with JACK Setup

Postby tramp » Mon Apr 10, 2017 9:16 am

fork wrote:Can anyone tell me what I should do to ditch Pulse and get JACK working...delete pulse, additional config, etc?


Check this out, it may suit your needs ( or not ) . .
viewtopic.php?f=19&t=13234

folderol
Establlshed Member
Posts: 629
Joined: Mon Sep 28, 2015 8:06 pm
Location: Here, of course!
Contact:

Re: Problems with JACK Setup

Postby folderol » Mon Apr 10, 2017 7:07 pm

Personally I just delete pulseaudio (the server) and leave everything else alone. Has the double benefit of killing all the annoying bings and bongs that apps seem to insist on.


Return to “Developer's Section”

Who is online

Users browsing this forum: No registered users and 2 guests