Can't compile edcast? I've got a solution for ya :)

Programming applications for making music on Linux.

Moderators: khz, MattKingUSA

User avatar
unfa
Established Member
Posts: 113
Joined: Tue May 17, 2011 10:43 am
Location: Warsaw, Poland
Contact:

Can't compile edcast? I've got a solution for ya :)

Postby unfa » Mon Oct 31, 2011 11:39 pm

Hi!

I'm working on setting up Rivendell on Ubuntu 10.04.2.

I needed to feed a shoutcast server with radio stream, and edcast, seemed to be the only option.
I got the sources of version 56 (?) from SVN, but I couldn't compile it.

After a lot of trying different things, I found out I have to modify one makefile for it to work...

Make sure you have Lame installed the latest version. I needed to compile Lame 3.99 from sources:
http://sourceforge.net/projects/lame/files/lame/3.99/

Then run ./autogen.sh in your edcast_jack directory. It will create a Makefile, which you need to modify (remove four characters).

Code: Select all

/edcast_jack/Makefile


Line 167 should look like this:

Code: Select all

LIBFLAC_LIBS = -lFLAC -logg -lm


And line 169 should look like this:

Code: Select all

LIBS =   -lpthread -logg -lvorbis -lmad  -lmp3lame -lm -lvorbisenc -lvorbisfile -lfaac -lm -lFLAC -logg -lm -ljack -ldl


I've removed the extra "-L"s before "-lFLAC"s.

Saved the file, then make and sudo make install did the job. Hell yeah!

Return to “Developer's Section”

Who is online

Users browsing this forum: No registered users and 1 guest